Photoshop Requires Legacy Java 6 (OSX)

It is a sad fact that my old version of Photoshop (CS4) requires a Java 6 installation to start. This is especially cumbersome, because OSX keeps removing Java 6 after OS updates (to eliminate the security threat, I assume)… Since it always takes me some time to find where I can download the installer again, I thought I’d share the link here:

https://support.apple.com/kb/dl1572

Hope it safes someone some time. Hi there, future me! 😉

Categories:

Updated:

Leave a Comment